Seiten: [1]   Nach unten
Drucken
Autor Thema: Fehler/Problem in PriMus 1.x  (Gelesen 415 mal)
weiwo
Novize
*
Beiträge: 2


Profil anzeigen
« am: 12. September 2018, 21:59:37 »

Hallo,
Ich war früher ScorePerfect Benutzer und habe – aus bekannten Gründen – eine Alternative gesucht. Am Besten entsprochen hat mir PriMus (Publisher). Mit der Aussicht auf eine neue Version habe ich manche Fehler/Probleme akzeptiert – zumal es ja fast überall einen Workaround gab.
Da die Version 2 aber jetzt schon sehr überfällig ist, darf ich hier doch einmal um Hilfe für meine Anliegen bitten. Vielleicht können mir ja andere User (bzw. Hr. Schardt aus erster Quelle) helfen.
Problem 1: Warnings am Druckoutput:
Es tauchen bei den Ausdrucken zum Teil Warnungen am Ende des Dokumentes auf. Die Warnungen sagen mir nichts und der Ausdruck scheint in Ordnung zu sein. Ich muss nur immer so formatieren, dass diese Warnings auf neue Seite kommen, damit ich sie beim Drucken unterdrücken kann.
Kann man die Ausgabe der Warnings/Fehler in den Druckoutput verhindern (weil dort haben sie absolut nichts verloren!)
Bsp. Für derartige Warnings:
2 Warnings:
Warnung: Verschachtelte Balken nur bei Vorschlagnoten zugelassen!
Takt : 15
Zeile 0
Warnung: _V->beamStatus falsch (nicht offen) ignoriere
Stimme: 2
Takt : 5
Zeile 0
1 Warnings:
Warnung: _V->beamStatus falsch (nicht offen) ignoriere
Takt : 159
Zeile 0
2 Warnings:
Warnung: _V->beamStatus falsch (nicht offen) ignoriere
Takt : 9
Zeile 0
Warnung: _V->beamStatus falsch (nicht offen) ignoriere
Takt : 108
Zeile 0

Problem 2: Abspielen von Partituren
Meine Arrangements (für Blasorchester) haben meist mehr als 20 Systeme.
Der Klang beim Abspielen ist mir eigentlich egal – ich will nur hören, ob ich mich wo verschrieben habe (Transponierung, Vorzeichen …).
Leider verhält sich PriMus hier sehr fehlerhaft:
- manche System werden gar nicht wiedergegeben.
- bei manchen Stimmen werden nur manche Noten nicht wiedergegeben
- manche Stimmen werden falsch wiedergegeben (z. Bsp. 1x falsch bei der Wiederholung richtig!)
- die Verwendung des Mixers ist absolut unmöglich (Stumm bzw. Solo Taster machen irgendwas, nur nicht, was man erwarten würde)
Das hat mich bei meiner letzten Partitur fast verzweifeln lassen – ich war der Meinung, die Noten sind absolut richtig – die Wiedergabe mit PriMus klang zum Teil grauenhaft.
(Ich habe die Partitur als XML exportiert – in  MuseScore eingelesen: und siehe da, alles klang richtig.)

Vielleicht gib‘s für meine Probleme Abhilfe bzw. best practice.
Noch besser wäre natürlich Lösung in und mit PriMus 2.0.

Vielen Dank für‘s Zuhören  - bzw. Lesen
lg
Wolfgang
Gespeichert
Christof Schardt
Erleuchteter
****
Beiträge: 369


Profil anzeigen WWW
« Antworten #1 am: 13. September 2018, 00:27:33 »

Problem 1: Warnings am Druckoutput:
Problem 2: Abspielen von Partituren

1. Warnungen: Weisen darauf hin, daß beim Import Probleme entstanden und bieten die Gelegenheit, in den gemeldeten Takten einen Prüfungsblick auf die Objekte wie z.B. Balken zu werfen.
Danach: Löschen mit Rechtsklick (Kontextmenü).

2. Abspielen von Partituren: Es gibt nur 16 Midikanäle, ohne Schlagzeug 15, da sind einige Stimmen dann von PriMus auf demselben Kanal auszugeben. Das kann zu überraschenden Effekten führen, wenn man die Kanäle nicht beachtet. Ich vermute, die Probleme liegen daran.  Am besten schickst Du die pri-Datei mal ein (support@columbussoft.de), dann können wir das mal ansehen und eine Lösung vorschlagen.
Übrigens gibt es unter Midi > Abspieloptionen die Einstellung "Ein Kanal pro Midiklang", mit der die Verteilung der Kanäle bei mehr als 15 Systemen besser hinkommt.
Gespeichert

Gruß Christof
weiwo
Novize
*
Beiträge: 2


Profil anzeigen
« Antworten #2 am: 13. September 2018, 09:37:26 »

Danke für die rasche Antwort (um Mitternacht - alle Achtung!)
Das mit dem Text Löschen mit der rechten Maustaste funktioniert – und wird meine Arbeit sicherlich erleichtern (Insbesondere bei den Einzelstimmenauszügen!)
(Ich bin aber trotzdem der Meinung, dass diese Warnungen auf dem Druckoutput nichts verloren haben!)

Was die Midi-Wiedergabe betrifft:
Selbstverständlich habe ich mit den Abspiel-Optionen experimentiert.
Keine funktioniert richtig.

Das mit Schicken der *.pri an support@columbussoft.de hatte ich mir sogar schon länger vorgenommen. Aber ich war mir nicht sicher, ob ich da nicht auf PriMus 2.x warten sollte.
Außerdem ist es auch zeitaufwändig, die Fehler/Problem so zu beschreiben, dass sie für die Entwickler/Programmierer auch verständlich und nachvollziehbar sind (Ich arbeite selbst in der IT-Branche). Und die Zeit ist natürlich immer knapp! Aber ich nehm es mir vor.

Trotzdem Danke Hr. Schardt

Grüße aus Österreich
Wolfgang

p.s.
Wie sieht‘s eigentlich tatsächlich mit PriMus 2.x aus.
Gespeichert
Christof Schardt
Erleuchteter
****
Beiträge: 369


Profil anzeigen WWW
« Antworten #3 am: 13. September 2018, 11:34:28 »

Das mit Schicken der *.pri an support@columbussoft.de hatte ich mir sogar schon länger vorgenommen.
... zeitaufwändig, die Fehler/Problem so zu beschreiben, dass sie für die Entwickler/Programmierer auch verständlich und nachvollziehbar sind

Ja, das ist richtig. Aber manchmal reicht auch eine kurze Notiz, um uns auf den Fehler zu führen. Und wenn nicht fragen wir nach, oder Walter Mink ruft zurück und schaltet sich mal mit dem Teamviewer auf. Manchmal sind es ja Kleinigkeiten, die große Verwirrung auslösen, aber eigentlich schnell zu lösen sind.
Gespeichert

Gruß Christof
Andreas
Adept
**
Beiträge: 92


Profil anzeigen
« Antworten #4 am: 16. September 2018, 20:00:10 »

Hallo, Wolfgang,

knobele auch gerne. Wenn Du mir mal eine PriMus-Datei schicken würdest, würde ich mir die Wiedergabe-Probleme gerne einmal ansehen/anhören.

Viele Grüße
Andreas
Gespeichert

Programme: PriMus, SharpEye, SmartScore
Betriebssystem: Win10
Musik: Kirchenmusik, Blasorchester, Tanzmusik
Seiten: [1]   Nach oben
Drucken
 
Gehe zu: